Jump to content
  • 0
XII360

Mobile view -- not displaying last poster on thread

Question

So yea, noticed this a while back, but at first thought it was my phone, but im not so sure anymore, thats why i creqted this thread

have yet to also this on other browsers on my phone but initially, the problem is: from mobile view, while ticked on *desktop view* or not, it does not display the last user to have posted on the thread (which is annoying to be honest), think its a problem on phones only ?

Also, anyone else, who uses phone to surf AF got this same problem ?

(Refer to images for example)

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

I had noticed as well but for me it is a godsend. My tiny screen and general lack of hand eye coordination usually sent me to the person's profile as opposed to their last post!  Maybe a happy glitch? Hehe....

Share this post


Link to post
Share on other sites
  • 0

Hi @XII360 nothing has changed recently in regards to the theme. It has been like that since Day 1 when we moved to this platform for mobile users.

Having said that, it looks like your mobile device has more width than mine (but the width is still small enough for the responsive layout kicks in)

This is how it looks for me:

229619455_PNGimage1.thumb.png.247f2dd1c385895b632eb7a2822fb02f.png

Out of curiosity what mobile device are you using?

 

  • Useful 1

Share this post


Link to post
Share on other sites
  • 0

How things are displayed will be impacted by the browser you use. It may differ as well based on mobile device as well as version of your phone browser. I use Firefox for Android, and that seems to work fine. You may try updating your browser app to see if that helps. Thing is mobile devices are very varied with how they view software like IPB forums which is what we use. So its really just a case of trial, and error.

Share this post


Link to post
Share on other sites
  • 0

Just woke up, my bad,

@Optic @ArchieKunim using samsung s7 active, incidentally, my main problem is,  <while desktop site/desktop view is ticked, latest individual wont diaplay>, so i dont think its screen width problem

Incidentally, the browser i use is "brave"

Ill gladly try another browser you guys want me to try though

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, XII360 said:

Just woke up, my bad,

@Optic @ArchieKunim using samsung s7 active, incidentally, my main problem is,  <while desktop site/desktop view is ticked, latest individual wont diaplay>, so i dont think its screen width problem

Incidentally, the browser i use is "brave"

Ill gladly try another browser you guys want me to try though

I see I don't think its a screen with issue either because I tried just now viewing the site from my phone, Mine is a LG Stylo budget phone so if any phone was to have issues you'd think it would be mine. Though ya I am thinking you may want to try Firefox, or chrome. Chrome has made a lot of strides in the mobile market lately so that may be your best option. It worked for me on both. :I would also add that at least for me I have a easier time browsing forums this one included with portrait mode holding my phone vertical.

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, ArchieKun said:

I see I don't think its a screen with issue either because I tried just now viewing the site from my phone, Mine is a LG Stylo budget phone so if any phone was to have issues you'd think it would be mine. Though ya I am thinking you may want to try Firefox, or chrome. Chrome has made a lot of strides in the mobile market lately so that may be your best option. It worked for me on both. :I would also add that at least for me I have a easier time browsing forums this one included with portrait mode holding my phone vertical.

Will try it once electricity kicks back up, and post back ASAP, statim, couse this 1.70gb of.mobile data is my.lifeline to internet access >.>...

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, XII360 said:

Will try it once electricity kicks back up, and post back ASAP, statim, couse this 1.70gb of.mobile data is my.lifeline to internet access >.>...

Oh you have limited mobile data that could also be an issue with data throttling when you get closer to your data cap. If that is the case there is nothing you can do except upgrade, or ask your service provider.

Share this post


Link to post
Share on other sites
  • 0

@ArchieKun nope, i doubt its.mobile data problem, as i dont use data if theres a stable connection (we have unli-dsl connection) (which is whenever.im home, plus the plan i have does not set a limit on useage, its just *use data as much as you want, go past 2gb and were cutting it.off*, which rarely happens (take note, my.mobile data is at 1.7gb, while the primary/staring point is 2gb, so ive initially burned 300mb so far only)

 

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, XII360 said:

@ArchieKun nope, i doubt its.mobile data problem, as i dont use data if theres a stable connection (we have unli-dsl connection) (which is whenever.im home, plus the plan i have does not set a limit on useage, its just *use data as much as you want, go past 2gb and were cutting it.off*, which rarely happens (take note, my.mobile data is at 1.7gb, while the primary/staring point is 2gb, so ive initially burned 300mb so far only)

 

Well its hard to say honestly. I would try the different browsers to see if that helps. In my experience chrome, and Firefox work the best as I mentioned. Otherwise I am honestly not sure I'd have to be handling your phone to really play with the settings, or other things on it.

Share this post


Link to post
Share on other sites
  • 0

Ill try other browser once nets back, so we can rule out *mobile data cap* possibilities, (but im 100% sure its not that)

Beocat seemed to have had the same proble. As mine, or atleast experienced it, any other user experience this, be sure to reply in the thread for everyone to know

incidentally, @ArchieKun, @Optic, this is what my screen looks like non-zoomed, desktop view.ticked (as i leave it ticked) (refer to spoiler)

Screenshot_20180915-065241.png

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, XII360 said:

Ill try other browser once nets back, so we can rule out *mobile data cap* possibilities, (but im 100% sure its not that)

Beocat seemed to have had the same proble. As mine, or atleast experienced it, any other user experience this, be sure to reply in the thread for everyone to know

Actually the main reason I wanted you to try several different browsers is that different browsers display pages different. For example one site may work like butter smooth, and then on a different browser the exact same site will tank, or display things improperly. Its more in the back end of the site with how its coded. In this case its lily a combination of your phone resulution not liking the forum, and the forum just not displaying right with your browser. This is especially true if things are not loading well like you miss the last post in a topic for example.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, XII360 said:

incidentally, @ArchieKun, @Optic, this is what my screen looks like non-zoomed, desktop view.ticked (as i leave it ticked) (refer to spoiler)

Thanks for the screenshot of your full view on mobile whilst in desktop mode.

So to clarify:

1. We don't actually have a dedicated mobile site. The theme is responsive based.

Which means as your browser width reduces, things and columns on the side start to disappear (the sidebar being the main one). You can actually test this on your desktop if you resize your browser window width 

So because of this, there shouldn't be any difference if Desktop Site mode is enabled in your mobile browser.

I just find it odd that on your Samsung Galaxy S7 the viewport width is so big it accommodates the sidebar? I would have expected it to be similar to my first screenshot.

Looking at Google's Material database your phone has a viewport resolution of 360px x 640px:

samsung-galaxy-s7-width.thumb.png.75f031fd56935bc324ccce55825b78cb.png

I'm a little confused because when I resize my browser window on my desktop to reproduce your screenshot, the width I get is around 1000px. To me this looks more like what I'd expect from a tablet in landscape mode.

1000px-v2.thumb.jpg.189ec9b8e33ff1974b337a5423eb0496.jpg

Are there any other features /settings on the Samsung Galaxy S7 that might be causing the sidebar to show up like that?

 

2. We can edit the theme to force that column to appear even if the sidebar appears in responsive mode

But I am worried this will be too squashy for mobile users if this is done for everyone.

When the theme is developed we use your viewport size as a reference (as per the above picture), so I can probably add a separate override for devices in-between.

As @ArchieKun noted there are many different mobile devices we need to cater for.

 

3. Also as a workaround, you can also try using the Activity Stream on mobile:

https://animeforums.net/discover/

  • Informative 1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Optic said:

Thanks for the screenshot of your full view on mobile whilst in desktop mode.

So to clarify:

1. We don't actually have a dedicated mobile site. The theme is responsive based.

A.> Which means as your browser width reduces, things and columns on the side start to disappear (the sidebar being the main one). You can actually test this on your desktop if you resize your browser window width 

So because of this, there shouldn't be any difference if Desktop Site mode is enabled in your mobile browser.<A

B.>I just find it odd that on your Samsung Galaxy S7 the viewport width is so big it accommodates the sidebar? I would have expected it to be similar to my first screenshot.<.B

Looking at Google's Material database your phone has a viewport resolution of 360px x 640px:

 

B.>I'm a little confused because when I resize my browser window on my desktop to reproduce your screenshot, the width I get is around 1000px. To me this looks more like what I'd expect from a tablet in landscape mode.<.B

C.>Are there any other features /settings on the Samsung Galaxy S7 that might be causing the sidebar to show up like that?

Wrote letters (which are bolded in quote) for the ones i comment on

A.) Ah, this actually makes sense, if theres no space for it to go onto, then naturally itll be removed, and i remember in an old thread, someone asking about mobile support, thats where i found out AF didnt support/create a mobile app

B.)  Im not sure either, im just using the phone as i use everytime, though maybe it has something to do with the phone model ?

The model of my.phone is *samsung s7 <active>* , but from what i searched, i think they both have the same ppi <which is 576>

C.) Not sure, but i tried touching some settings on display <refer to spoiler 《C.》>, but it yielded same result.

 

1 hour ago, Optic said:

2. We can edit the theme to force that column to appear even if the sidebar appears in responsive mode

D.>But I am worried this will be too squashy for mobile users if this is done for everyone.

When the theme is developed we use your viewport size as a reference (as per the above picture), so I can probably add a separate override for devices in-between.

As @ArchieKun noted there are many different mobile devices we need to cater for.<.D

 

3. Also as a workaround, you can also try using the Activity Stream on mobile:

Z.> https://animeforums.net/discover/ <.Z

D.) If it causes more harm.to other user's experience, i say nay, but it wont hurt to try (and while were at it, others can try too, and see if it improves interface for mobile users (not just my.phone's), or if it makes it worse

Z.) Ill keep this in mind, as this can be a fix of sort on not displaying who last posted on threads

Also, @ArchieKun, i tried other browsers (as we have electricity again), it yielded same results, both chrome and firefox (refer to spoiler)

Spoiler images 

(Im still fixing it)

《C》;

 

Screenshot_20180915-120005.pngScreenshot_20180915-115634.png

 

chrome/fox;

 

 

Screenshot_20180915-111331.pngScreenshot_20180915-111205.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Anime Forums

A unique community of fans from around the world, who gather to share their fandom and love of anime, manga, gaming, fanart and at the cornerstone of it all, Japanese culture!

Take a moment to join us today and you'll have access to our member clubs and events too. Come join in the fun and become a part of our community.
insta-1

twit
×
×
  • Create New...